Programming WebRTC: npm run ssl-keys not working (page 4)

Windows 11 fully updated, added openssl to the PATH, node also installed. When running command:

npm run ssl-keys --keydir=“C:\dev\Certs” --numdays=1825

I got error:

req: Can’t parse “$npm_config_numdays” as a number
req: Non-positive number “$npm_config_numdays” for -days

I was able to generate the certificates by manually replacing the path and numdays:

openssl req -x509 -out C:\dev\Certs\localhost.crt -keyout C:\dev\Certs\localhost.key -newkey rsa:2048 -nodes -sha256 -days 1825 -subj ‘/CN=localhost’ -extensions EXT -config scripts/conf/self-signed.conf

I switched to Linux to follow the book, clearly the code was not tested on a Windows machine. Personally I don’t mind, but it may be a good idea for the author to test on a Windows machine given the number of Windows users. Alternatively, the book could suggest to Windows users to enable WSL2.

Thanks for letting me know, Paul! We had another thread on a very similar topic, but yes–WSL is probably the better work around for now, although I am also looking into making the npm stuff a little more cross-platform.

There is no technical reason for the book software to not run on Windows. It just need to be tested and slightly modified.