Intuitive Python: docker run… denied error (page 2)

Title: Intuitive Python: docker run… denied error (page 2)

Attempted to run the docker command in both CLI and Powershell
PS C:\Users\rmurr> docker run --pull=always --interactive --tty --rm ghcr.io/davidmuller/intuitivepython-book/intuitive-python-book:latest /bin/bash
docker: Error response from daemon: Head https://ghcr.io/v2/davidmuller/intuitivepython-book/intuitive-python-book/manifests/latest: denied.
See ‘docker run --help’.

Tried … --pull=“always” …
Same error

Hi @rmurray10127 it looks like there is a typo in the above command. intuitivepython-book should be intuitive-python-book.

Here’s a full docker run command without the typo that should work:

docker run --pull=always --interactive --tty --rm ghcr.io/davidmuller/intuitive-python-book/intuitive-python-book:latest /bin/bash

Thanks for your reply. It looks like the typo was induced by my cut/paste from the text. I used Foxit and also tried Adobe Acrobat DC. There is something about the first line ending with a ‘-’ that neither tool likes. Sorry for the wild goose chase.

Ah got it—that’s a frustrating cut/paste behavior.

I will see if there’s an alternate way we can layout that part of the book so it’s more likely to behave better with cut/paste.

Hi,
I have seen another behavior related to docker. It seems that docker and Virtualbox will not run on Windows 10 workstation. There is lots of Google traffic on the topic ranging from definitely yes to definitely no. I cannot find any yes solution that is doable by the casual user. The behavior I saw was docker runs fine but the VMs in VirtualBox will not start. I think this is due to a conflict on the use of Windows HyperV. I wonder how many of your readers will be using Virtualbox for some other activity, and may run into this problem? I am not sure that this issue is in your scope , but thought you could use the information.

1 Like