How to have a Neovim configuration compatible with Vim

How to have a Neovim configuration compatible with Vim.
So you can have your cake and eat it too.

Read in full here:

This thread was posted by one of our members via one of our news source trackers.

Corresponding tweet for this thread:

Share link for this tweet.