Erlang's not installing on macOS Big Sur "You are natively building Erlang/OTP for a later version of MacOSX than current version"

Just done a fresh install of macOS Big Sur and on installing Erlang I am getting:

asdf install erlang 23.1.2
Configure failed.
checking OTP version... 23.1.2
configure: error: 

  You are natively building Erlang/OTP for a later version of MacOSX
  than current version (11.0.1). You either need to
  cross-build Erlang/OTP, or set the environment variable
  MACOSX_DEPLOYMENT_TARGET to 11.0.1 (or a lower version).

ERROR: /Users/Aston/.asdf/plugins/erlang/kerl-home/builds/asdf_23.1.2/otp_src_23.1.2/make/configure failed!

Doing:

export MACOSX_DEPLOYMENT_TARGET=11.0.1
asdf install erlang 23.1.2 

Does not work for me, and from: https://github.com/erlang/otp/blob/master/make/configure.in

	   test $int_macosx_version != unexpected || {
	   	AC_MSG_ERROR([Unexpected MacOSX version ($macosx_version) returned by 'sw_vers -productVersion'; this configure script probably needs to be updated])
	   }

I see "this configure script probably needs to be updated" so I guess it just means it’s a case of waiting for the team get around to it?

(I’m in no immediate rush so don’t mind waiting…)

1 Like
1 Like

Try with this instead:

export MACOSX_DEPLOYMENT_TARGET=10.0

3 Likes

Thanks @xalxor it works :nerd_face: :+1:

Erlang bug tracker link: https://bugs.erlang.org/browse/ERL-1407

Specifying deployment target 10.0 worked for me as well in the meantime. According to the metadata of the above ticket, Erlang 23.2 is going to fix the problem.

2 Likes

BTW yep, Erlang 23.2 doesn’t have the problem.

1 Like

The biggest fear when you update your Mac OS and crash the entire environment, so sad this incompatibility every time they lunch a new version.

Well, right now on Big Sur trying to install the latest Erlang 22 still doesn’t work, even with issuing MACOSX_DEPLOYMENT_TARGET=10.0 asdf install erlang 22.3.4.14.

So yeah, not ideal. :frowning: But I will resist having to use Docker for a while still. :smiley:

But maybe when I buy a Linux workstation I’ll go that route.

1 Like

Can you enter this in terminal first:

export MACOSX_DEPLOYMENT_TARGET=10.0

And then try to install?