Effective Haskell: example function name is misleading (page 79)

In one version of the function isBalanced, it uses a helper function named checkBalance to change the running count of how balanced (or not) the string is.

I think the “check” prefix there is misleading, since it implies a boolean good/bad result, not a running total. I think “countParens” or “trackBalance” something along those lines would be a better name.