Modern Asynchronous JavaScript: using variable name inside its iterator? (page 7)

Within the body of the asynchronous iterator, the code uses srcArr to refer to the array it’s being called on; since it’s a named function and not an arrow func, why not usethis instead? Seems like that would be less brittle and more general.