Doom-Emacs: Can't find emacs in your PATH

If you get Can't find emacs in your PATH when trying to install Doom Emacs on your Mac you… just… need to install Emacs first! :lol:

brew install emacs

OR if you want to use the Emacs Plus homebrew formula:

Emacs Plus is GNU Emacs formulae for macOS Homebrew package manager. It offers a wide rage of extra functionality over regular Emacs package. Emacs Plus intent is to give the most of ‘plus’ stuff by default, leaving only controversial options as opt-in.

First see which icon you want to use from here then replace --with-modern-doom3-icon with it on the second line:

brew tap d12frosted/emacs-plus

brew install emacs-plus --with-modern-doom3-icon

git clone --depth 1 ~/.emacs.d
~/.emacs.d/bin/doom install

It should then be installed :tada:


Corresponding tweet for this thread:

Share link for this tweet.

1 Like